Requesting [FREE] Citizens Version Help

I feel like I'm helpless but, can someone send me the correct version for citizens 1.8.9. I've downloaded and tried sooo many but none work.

Could someone also tell me how to use deluxemenus with placeholderapi (server selector) but I also use featherboard with makes u use mvdwplaceholders and placeholderapi doesn't work because mvdw plugin doesn't let it.
 
Top